Saturday, August 30, 2008

r68 with Ubuntu/Debian Installer

While setting m4s up on my new laptop, I got frustrated with perl mods. Calling 'sudo make pmods_ubuntu' will now install all prerequisite perl modules.

Cheers,
--Travis

1 comment:

.0vScm8kwNZmjo9K1tQvUdFXfeD_ said...

Should it work on Dapper?

a@b:/tmp/msp430static$ sudo make pmods_ubuntu
apt-get install libdbi-perl libdbd-sqlite3-perl libgd-gd2-perl libterm-readline-perl-perl xloadimage
Reading package lists... Done
Building dependency tree... Done
libdbi-perl is already the newest version.
libdbd-sqlite3-perl is already the newest version.
The following extra packages will be installed:
libgd2-xpm
Suggested packages:
libgd-tools
The following packages will be REMOVED
libgd-gd2-noxpm-perl libgd2-noxpm
The following NEW packages will be installed
libgd-gd2-perl libgd2-xpm libterm-readline-perl-perl xloadimage
0 upgraded, 4 newly installed, 2 to remove and 73 not upgraded.
Need to get 569kB of archives.
After unpacking 492kB of additional disk space will be used.
Do you want to continue [Y/n]? Y
Get: 1 http://nixabdn-bug dapper-updates/main libgd2-xpm 2.0.33-2ubuntu5.4 [195kB]
Get: 2 http://nixabdn-bug dapper/universe libterm-readline-perl-perl 1.0203-3 [44.0kB]
Get: 3 http://nixabdn-bug dapper/universe xloadimage 4.1-16 [112kB]
Get: 4 http://nixabdn-bug dapper/main libgd-gd2-perl 1:2.30-1 [218kB]
Fetched 569kB in 22s (25.2kB/s)
(Reading database ... 181710 files and directories currently installed.)
Removing libgd-gd2-noxpm-perl ...
dpkg: libgd2-noxpm: dependency problems, but removing anyway as you request:
python2.4-gd depends on libgd2-noxpm (>= 2.0.33) | libgd2-xpm (>= 2.0.33); however:
Package libgd2-noxpm is to be removed.
Package libgd2-xpm is not installed.
gnuplot-nox depends on libgd2-noxpm (>= 2.0.33) | libgd2-xpm (>= 2.0.33); however:
Package libgd2-noxpm is to be removed.
Package libgd2-xpm is not installed.
Removing libgd2-noxpm ...
Selecting previously deselected package libgd2-xpm.
(Reading database ... 181659 files and directories currently installed.)
Unpacking libgd2-xpm (from .../libgd2-xpm_2.0.33-2ubuntu5.4_i386.deb) ...
Selecting previously deselected package libterm-readline-perl-perl.
Unpacking libterm-readline-perl-perl (from .../libterm-readline-perl-perl_1.0203-3_all.deb) ...
Selecting previously deselected package xloadimage.
Unpacking xloadimage (from .../xloadimage_4.1-16_i386.deb) ...
Selecting previously deselected package libgd-gd2-perl.
Unpacking libgd-gd2-perl (from .../libgd-gd2-perl_1%3a2.30-1_i386.deb) ...
Setting up libgd2-xpm (2.0.33-2ubuntu5.4) ...
Setting up libterm-readline-perl-perl (1.0203-3) ...
Setting up xloadimage (4.1-16) ...

Setting up libgd-gd2-perl (2.30-1) ...
al@b:/tmp/msp430static$ m4s
DBD::SQLite::db do failed: near "NOT": syntax error(1) at dbdimp.c line 269 at /tmp/msp430static/MSP430static.pm line 205.
DBD::SQLite::db prepare failed: no such table: macros(1) at dbdimp.c line 269 at /tmp/msp430static/MSP430static.pm line 159.
DBD::SQLite::db do failed: near "not": syntax error(1) at dbdimp.c line 269 at /tmp/msp430static/MSP430static.pm line 141.
DBD::SQLite::db prepare failed: no such table: subs(1) at dbdimp.c line 269 at /tmp/msp430static/MSP430static.pm line 86.
Couldn't prepare statement: no such table: subs(1) at dbdimp.c line 269 at /tmp/msp430static/MSP430static.pm line 86.
.